Testnet 0.8.1 live!

A new enhancement version 0.8.1 is now live. You can refer to the binaries/release information here:

If you are running a validator, please use the unjail command through the example in the README.
It is a small update, so you won’t have to set everything up again–just changing the binary will be enough.

after this update cant unjail my node and can’t send any tx to the network:

certikcli tx slashing unjail --from=novy --chain-id=shentu
Enter keyring passphrase:
{“chain_id”:“shentu”,“account_number”:“13910”,“sequence”:“2”,“fee”:{“amount”:[],“gas”:“200000”},“msgs”:[{“type”:“cosmos-sdk/MsgUnjail”,“value”:{“address”:“certikvaloper1uwg8g9t3e40qvjld0gk4qcgrawzr58qp3q48jm”}}],“memo”:""}

confirm transaction before signing and broadcasting [y/N]: y
Enter keyring passphrase:
height: 0
txhash: 9CA085D6B263BC683807E1C0C075ED71A71376A364032CC44CF91413D5741917
codespace: “”
code: 19
data: “”
rawlog: “”
logs: []
info: “”
gaswanted: 0
gasused: 0
tx: null
timestamp: “”

novy@novy:~$ certikcli q tx 9CA085D6B263BC683807E1C0C075ED71A71376A364032CC44CF91413D5741917
ERROR: Tx: RPC error -32603 - Internal error: tx (9CA085D6B263BC683807E1C0C075ED71A71376A364032CC44CF91413D5741917) not found

fixed by adding fee flag

In the process of syncing the node, I encountered the need to restart it. What caused the inability to return to the node synchronization mode.
The system returns an error,

root@server:~# ./certikd start
I[2020-05-12|08:03:07.454] starting ABCI with Tendermint module=main
failed to load Store: wanted to load target 523700 but only found up to 520000

Is it possible to fix this somehow, I can suspect that with any server restart, a similar problem is possible.

Hello MBGBuzzer, you could try giving it

–pruning nothing

flag with the start command. So you would start by

certikd start --pruning nothing

Could you try this?

Well, we will try, but after the next reboot.
Now we are synchronizing the database with the new one.

root@server:~# ./certikd start
I[2020-05-12|21:41:32.374] starting ABCI with Tendermint module=main
failed to load Store: wanted to load target 59100 but only found up to 50000
root@server:~# ./certikd start --pruning nothing
I[2020-05-12|21:42:07.511] starting ABCI with Tendermint module=main
failed to load Store: wanted to load target 59100 but only found up to 50000

Same problem.
I tried it on different servers, but syncing doesn’t start, so I have to delete “data” and initialize it again.

and I have another question - what version of Tendermint do you use?

We are using tendermint 0.33.2. We are working on locating and fixing the issue. Please let us know if you have any further problems restarting the node.

1 Like

How is this possible?

Based on the situation in the picture above, I dare to assume that there is a quick synchronization and its validation after some time. The blocks were aligned, and everything worked as it should.
I launched the node!, Everything works fine!

Great! Thank you for reporting the errors. As this is still a testnet and the tendermint version we are using seems to be unstable from time to time, there can be such situations happening as well. If you encounter any further malfunctions/errors, please let us know and we’ll be happy to help :slightly_smiling_face:

2 Likes
May 20 20:26:09 certikd[798]: E[2020-05-20|20:26:09.619] Stopping peer for error                      module=p2p peer="Peer{MConn{3.84.243.54:26656} 75768fca7957c0b60cca23ea7cd8c7e8e87e9c44 out}" err=EOF
May 20 20:26:09 certikd[798]: E[2020-05-20|20:26:09.620] Stopping peer for error                      module=p2p peer="Peer{MConn{3.80.63.16:26656} b04eb82655a25e9470fb800cd661685a1f4ebd89 out}" err=EOF


I get this errors, please tell me what is that?

They are normal behaviors of disconnecting from a peer if there is a connection issue with the peer. No need to worry about.

1 Like

I was beginning to panic…Ok! Thank you!

Today i get this problem, the connection to the peers / servers was lost.


how do I solve this problem?
I’ve already tried “unsafe-reset-all” - but it doesn’t help.

Video:

Hi MBGBuzzer, please retry with:

seeds = "18c5729b0df2a1047b33b0519f98d1cf7c5e68b6@3.230.172.131:26656,f98cc70df4d9eaf08896f0d5d3e9c63ba6a1b86b@3.80.152.208:26656"
persistent_peers = "7b8b5361ba0573dbd928cedf09d54e0de3ba735c@3.95.65.2:26656,a30dbf79aafb7089e4619fb66a1628b033fb02ac@34.200.251.198:26656"
1 Like

OK, thanks! syncing started :crazy_face: :wave:
I continue to test the network.

Syncing is in progress…
but after I made the changes I have a status request via the command
./certikcli status
and get this:
ERROR: Status: Post failed: Post "http://3.95.195.221:26657": dial tcp 3.95.195.221:26657: connect: connection refused

Hi MBGBuzzer, certikcli would by default connect to http://localhost:26657 which is provided by the running certikd. Can you check your [rpc] laddr field of the .certikd/config/config.toml? Also is the --home flag being set correctly?

1 Like